close

Slick­Stack

July 2024 promo! Join our Discord free of charge.

Slick­Stack
Lightning-fast WordPress on Nginx

ERR_TOO_MANY_REDIRECTS on WP Multisite

  • This topic is empty.
Viewing 13 posts - 1 through 13 (of 13 total)
  • Author
    Posts
  • #7104 Reply
    Megan
    Guest

    Hi,

    A clean WP install with multisite enabled in ss-config (using the interactive guide) on a fresh updated Ubuntu VPS server – I get ERR_TOO_MANY_REDIRECTS.

    I have googled this and SSL I already set to Full on Cloudflare:

    Redirect Loops

    What else can be causing this? I got no errors during install.

    Installing without WP multisite enabled in ss-config makes everything work fine but I need multisite running on this server.

    #7105 Reply
    Diane
    Guest

    You must comment out these lines first in your wp-config.php

    /** comment these out on new installs and visit WP Admin >> Tools >> Network Setup */
    define('MULTISITE', true); // ss = true
    define('SUBDOMAIN_INSTALL', @WP_MULTISITE_SUBDOMAINS); // ss = true
    // define('DOMAIN_CURRENT_SITE', '@SITE_DOMAIN'); // ss = *must be unique*
    define('DOMAIN_CURRENT_SITE', $_SERVER['HTTP_HOST']);
    define('NOBLOGREDIRECT', 'https://@SITE_DOMAIN'); // ss = *must be unique*
    define('PATH_CURRENT_SITE', '/'); // ss = /
    define('SITE_ID_CURRENT_SITE', 1); // ss = 1
    define('BLOG_ID_CURRENT_SITE', 1); // ss = 1

    And then visit WP Admin >> Tools >> Network Setup and follow that wizard.

    #7106 Reply
    Albert
    Guest
    #7107 Reply
    Bruce
    Guest

    After you finish the wizard in WP Admin, you can re-run ss install

    Or just ss install wp config again.

    #7108 Reply
    Jean
    Guest

    This is due to shortfall in SS ability to configure the database fully for WP Multisite, we never finished reviewing how to make it work smoother… I think WP-CLI can do this but I’m not sure how they do it.

    #7111 Reply
    Jonathan
    Guest

    Thank you all – appreciate all the help. WP Multisite is all installed now! Iøm not sure how it works though.

    The next problems:
    1. How do I create new subsites (with top level xxx.com, yyy.com domains etc. – not subdomains) and create the SSL certificates for each separate top level domain? I don’t see any way.

    2. How do I change the domains of each of those subsites under Slickstack (eg. change xxx.com to vyx.com and yyy.com to abc.com)?

    #7112 Reply
    Natalie
    Guest

    3. When I go to wp-admin/network/ I get a No Permissions error. I can’t seem to create new sites.

    #7114 Reply
    Brian
    Guest

    1. How do I create new subsites (with top level xxx.com, yyy.com domains etc. – not subdomains) and create the SSL certificates for each separate top level domain? I don’t see any way.

    This is not possible unless you use Cloudflare. Just make new subsites with existing domains in your Cloudflare, point the IP address to your SS server.

    SlickStack / WordPress supports automatic domain mapping, there is nothing special needed besides using OpenSSL + Cloudflare

    #7115 Reply
    Adam
    Guest

    3. When I go to wp-admin/network/ I get a No Permissions error. I can’t seem to create new sites.

    Enable OpenSSL in ss-config, ensure Cloudflare is active. Then run ss install completely again. Then purge your caches ss purge and reset all permissions ss perms and then clear cookies for this site in your browser and try again.

    #7169 Reply
    Abigail
    Guest

    No purging or ss-install solved it. I now erased the server and tried again with everything fresh. I get “Registration has been disabled.” whenever visiting wp-admin or wp-login.pho after pasting the Network setup code from the NetWork Setup section in WordPress. I have commented the existing network setup to deactivate it as mentioned in the wp-config file.

    Private Browser mode does not help. Neither does perms, purge commands or ss-install or ss-install wp-config

    Can’t figure out how to get this network startup.

    The pasted code is:
    define( ‘MULTISITE’, true );
    define( ‘SUBDOMAIN_INSTALL’, true );
    define( ‘DOMAIN_CURRENT_SITE’, ‘www.domain.com’ );
    define( ‘PATH_CURRENT_SITE’, ‘/’ );
    define( ‘SITE_ID_CURRENT_SITE’, 1 );
    define( ‘BLOG_ID_CURRENT_SITE’, 1 );

    Any ideas?

    #7170 Reply
    Mason
    Guest

    And running ss-install wp-config just resets the multisite setup – so I have to do Network Setop again. So I go around in circles.

    Each to I do Network Setup steps I get ERR_TOO_MANY_REDIRECTS

    Cloudflare Security is set to Full b.t.w.

    #7171 Reply
    Rachel
    Guest

    “Each time I do Network Setup” I meant

    #7173 Reply
    Timothy
    Guest

    >> after pasting the Network setup code

    Why are you pasting anything? You seem to be adding in more steps that are not required, all you do is comment the lines mentioned **the first time you setup Multisite** and visit Tools >> Network Setup… after you finish the wizard, there is no pasting of anything, because the lines exist already. Simply run ss install wp config at that point and it will regenerate the required lines for you.

Viewing 13 posts - 1 through 13 (of 13 total)
Reply To: ERR_TOO_MANY_REDIRECTS on WP Multisite

Thanks to our generous sponsors for their support!